Advertisement

LEGO Harry Potter: Years 5-7 System Requirements

LEGO Harry Potter: Years 5-7
Publisher: Warner Bros. Interactive Entertainment
Developer: TT Games
Minimum System Requirements
OS:
Processor:
Memory:
Hard Drive:
Video Memory:
Video Card:
Sound Card:
DirectX:
Keyboard
Mouse
DVD Rom Drive

Comment on This Game

No Comments.

Add a Comment





More System Requirements for the Following Games